Back to overview
Downtime
Pims is unavailable
Oct 09 at 11:39am EEST
Affected services
PIMS Portal
Resolved
Oct 09 at 11:49am EEST
Pims is back up, we are monitoring the situation
Affected services
Created
Oct 09 at 11:39am EEST
PIMS is currently down for most users. We’re actively working on a resolution and will update you as soon as possible.
Affected services