Back to overview
Degraded

Services degradation

Aug 27 at 12:10pm EEST
Affected services
PIMS Portal

Resolved
Aug 27 at 12:13pm EEST

A fix has been implemented and we are monitoring the results.

Created
Aug 27 at 12:10pm EEST

PIMS is currently slower than usual for most users. Our team is actively investigating and working to resolve the issue as quickly as possible. Thank you for your patience.