Back to overview
Degraded

Degraded performance

Aug 12 at 06:01pm EEST
Affected services
PIMS Portal

Resolved
Aug 12 at 06:19pm EEST

The issue causing slowness in Pims has been identified and resolved. The platform is now fully functional.

Created
Aug 12 at 06:01pm EEST

Pims is currently experiencing slowness for some users. Our developers are actively working to contain the issue and restore normal performance. Updates will be posted as they become available.