Back to overview
Degraded

Degraded performance

May 5, 2025 at 12:10pm UTC
Affected services
PIMS Portal

Resolved
May 5, 2025 at 12:20pm UTC

We have completed the data related process and the platform is back to normal.

Created
May 5, 2025 at 12:10pm UTC

The platform is slow for some of our users. A routine data update took longer than expected, causing users to experience slowness