Back to overview
Degraded

Platform slowness

Oct 29 at 03:11pm EET
Affected services
PIMS Portal

Resolved
Oct 29 at 06:38pm EET

Caching issue was resolved

Created
Oct 29 at 03:11pm EET

Platform is extremely slow due to issues in the caching layer