Back to overview
Degraded
Platform slowness
Oct 28 at 02:59pm EET
Affected services
PIMS Portal
Resolved
Oct 28 at 06:27pm EET
Platform recovered
Affected services
PIMS Portal
Created
Oct 28 at 02:59pm EET
Platform is extremely slow due to issues in the caching layer
Affected services
PIMS Portal